CVE-2026-6473 in PostgreSQL 18.*
Integer wraparound in multiple PostgreSQL server features allows an unprivileged database user to cause the server to undersize an allocation and write out-of-bounds. This may execute arbitrary code as the operating system user running the database. In applications that pass gigabyte-scale user inputs to the relevant database functions, the application input provider may achieve a segmentation fault. Versions before PostgreSQL 18.4, 17.10, 16.14, 15.18, and 14.23 are affected.
- Severity
- High 8.8
- Exploitation
-
1% chance of exploit
in the next 30 days - Fix
- Update to 18.4
- Where
- Workstation tool
- How it matched
- Version line match
- First seen
- 2026-11-05 01:13:58 UTC
- Source
- https://nvd.nist.gov/vuln/detail/CVE-2026-6473