SWS Vulnerability Watch

Back to findings

CVE-2026-2005 in PostgreSQL 18.*

Heap buffer overflow in PostgreSQL pgcrypto allows a ciphertext provider to execute arbitrary code as the operating system user running the database. Versions before PostgreSQL 18.2, 17.8, 16.12, 15.16, and 14.21 are affected.

Severity
High 8.8
Exploitation
1% chance of exploit
in the next 30 days
Fix
Update to 18.2
Where
Workstation tool
How it matched
Version line match
First seen
2026-11-05 01:13:58 UTC
Source
https://nvd.nist.gov/vuln/detail/CVE-2026-2005