CVE-2025-6965 in SQLite 3.46.*
There exists a vulnerability in SQLite versions before 3.50.2 where the number of aggregate terms could exceed the number of columns available. This could lead to a memory corruption issue. We recommend upgrading to version 3.50.2 or above.
- Severity
- High 7.7
- Exploitation
-
73% chance of exploit
in the next 30 days - Fix
- Update to 3.50.2
- Where
- Test dependency
- How it matched
- Version line match
- First seen
- 2026-11-05 01:13:58 UTC
- Source
- https://nvd.nist.gov/vuln/detail/CVE-2025-6965