SWS Vulnerability Watch

Back to findings

CVE-2026-19385 in PostgreSQL 18.*

Heap buffer overflow in PostgreSQL pg_dump of long function transform lists allows an object creator to execute arbitrary code as the operating system user running pg_dump, via a crafted transform list. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.

Severity
High 8.8
Exploitation
0% chance of exploit
in the next 30 days
Fix
Update to 18.5
Where
Workstation tool
How it matched
Version line match
First seen
2026-11-05 01:13:58 UTC
Source
https://nvd.nist.gov/vuln/detail/CVE-2026-19385