CVE-2026-15742 in PostgreSQL 18.*
Integer wraparound in PostgreSQL fuzzystrmatch allows a user to direct writes to a huge range of addresses, executing arbitrary code as the operating system user running the database, via extreme inputs to SQL function levenshtein() or levenshtein_less_equal(). Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.
- Severity
- High 8.8
- Exploitation
-
1% chance of exploit
in the next 30 days - Fix
- Update to 18.5
- Where
- Workstation tool
- How it matched
- Version line match
- First seen
- 2026-11-05 01:13:58 UTC
- Source
- https://nvd.nist.gov/vuln/detail/CVE-2026-15742