SWS Vulnerability Watch

Back to findings

CVE-2026-15741 in PostgreSQL 18.*

SQL injection in PostgreSQL EXTRACT() deparse allows an object owner to execute arbitrary SQL as a superuser via a hostile object definition. Attacks affect expression deparse consumers broadly, including pg_dump, psql commands like \sf, and any similar usage in non-core tools. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.

Severity
High 8.8
Exploitation
0% chance of exploit
in the next 30 days
Fix
Update to 18.5
Where
Workstation tool
How it matched
Version line match
First seen
2026-11-05 01:13:58 UTC
Source
https://nvd.nist.gov/vuln/detail/CVE-2026-15741