SWS Vulnerability Watch

Back to findings

CVE-2026-14676 in PostgreSQL 18.*

Heap buffer overflow in PostgreSQL pg_stat_statements allows the query author to execute arbitrary code as the operating system user running the database, via crafted queries containing array constants. Within major version 18, minor versions before PostgreSQL 18.6 are affected. Versions before PostgreSQL 18 are unaffected.

Severity
High 8.8
Exploitation
0% chance of exploit
in the next 30 days
Fix
Update to 18.5
Where
Workstation tool
How it matched
Version line match
First seen
2026-11-05 01:13:58 UTC
Source
https://nvd.nist.gov/vuln/detail/CVE-2026-14676