CVE-2026-14670 in PostgreSQL 18.*
Heap buffer overflow in PostgreSQL plperl return of a tied hash allows the function owner to execute arbitrary code as the operating system user running the database, via a crafted function body. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.
- Severity
- High 8.8
- Exploitation
-
0% chance of exploit
in the next 30 days - Fix
- Update to 18.5
- Where
- Workstation tool
- How it matched
- Version line match
- First seen
- 2026-11-05 01:13:58 UTC
- Source
- https://nvd.nist.gov/vuln/detail/CVE-2026-14670