SWS Vulnerability Watch

Back to findings

CVE-2026-14669 in PostgreSQL 18.*

Heap buffer overflow in PostgreSQL to_char(timestamptz) allows the party choosing the timezone to execute arbitrary code as the operating system user running the database, via a long POSIX timezone abbreviation. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.

Severity
High 8.8
Exploitation
1% chance of exploit
in the next 30 days
Fix
Update to 18.5
Where
Workstation tool
How it matched
Version line match
First seen
2026-11-05 01:13:58 UTC
Source
https://nvd.nist.gov/vuln/detail/CVE-2026-14669